Twilio IVR/SMS Payment Messaging Issues

Incident

Twilio IVR/SMS Payment Messaging Issues

Status: Closed
Start:
End:
Duration: 1 day 22 hours 39 minutes
Affected Components:
CUSI Third-Party Interfaces
Affected Groups:
CUSI
Investigating

CUSI's transparent and effective client communication is a top priority, and we are committed to providing you with regular updates regarding CUSI products.

CUSI is currently investigating an issue affecting Twilio, a third party service that is used for IVR and SMS messaging, reporting an error stating that "There was a problem with the provider."

Start Time: 4/22/26 @ 1:28pm CST

  • Impact: Twilio Users will be unable to send IVR/SMS messages.

  • Estimated Resolution: TBD

CUSI is working diligently to resolve the issue and will provide updates as soon as possible. Thank you for being so patient.

Resolved

CUSI is announcing that a resolution has been successfully deployed to address the Twilio IVR/SMS issue. Bluefin's technical team has made the necessary corrections, and CUSI and Bluefin are currently monitoring to ensure stability and effectiveness.

Current Status:

  • Resolution Deployed: A fix was deployed

  • Monitoring: CUSI and Bluefin are closely monitoring the performance and functionality to ensure that the issue has been fully resolved.

Actions Taken:

  • The technical team has identified and addressed the cause of the disruption.

  • Mitigation measures have been put in place to prevent recurrence.

  • Continuous monitoring is being conducted to track performance and detect any anomalies.

Next Steps:

  • Monitor Closely: Please be vigilant and report any irregularities or issues you may encounter.

  • Feedback: Feedback is crucial during this monitoring phase. If you notice any problems, please contact our technical support team immediately.

  • Updates: CUSI will provide regular updates on the status and any further actions required.

Monitoring

CUSI is announcing that a resolution has been successfully deployed to address the Twilio IVR/SMS issue. Bluefin's technical team has made the necessary corrections, and CUSI and Bluefin are currently monitoring to ensure stability and effectiveness.

Current Status:

  • Resolution Deployed: A fix was deployed

  • Monitoring: CUSI and Bluefin are closely monitoring the performance and functionality to ensure that the issue has been fully resolved.

Actions Taken:

  • The technical team has identified and addressed the cause of the disruption.

  • Mitigation measures have been put in place to prevent recurrence.

  • Continuous monitoring is being conducted to track performance and detect any anomalies.

Next Steps:

  • Monitor Closely: Please be vigilant and report any irregularities or issues you may encounter.

  • Feedback: Feedback is crucial during this monitoring phase. If you notice any problems, please contact our technical support team immediately.

  • Updates: CUSI will provide regular updates on the status and any further actions required.