Delayed ACH Funding from the Federal Reserve
Informational
2026-03-04T15:42:00.0000000Z
Delayed ACH Funding from the Federal Reserve
Status: Closed
Date:
2026-03-03T16:37:00.0000000Z
End:
2026-03-04T15:42:00.0000000Z
Duration: 23 hours 5 minutes
Affected Components:
CUSI Payment Services Bluefin
CUSI Third-Party Interfaces
Affected Groups:
CUSI
Update
2026-03-03T16:37:00.0000000Z
2026-03-03T16:37:00.0000000Z
Overview:
CUSI is aware of an internal issue at the Federal Reserve that is impacting the processing of ACH transactions.
As a result, merchants, including Bluefin and Jack Henry, may experience delays in receiving settlement funding to their accounts.
For more information on this issue please visit the Federal Reserve Status link:
Please Note:
This is a third-party caused incident and CUSI systems are fully operational and processing without issue.
Resolved
2026-03-04T15:42:00.0000000Z
2026-03-04T15:42:00.0000000Z
CUSI is pleased to inform you that the issues causing delays in ACH settlement activity have been resolved. The Federal Reserve has addressed the problem, and all processing systems continue to operate normally.
Copyright (C) 2025.