Electronic Payment Processing Latency Issues
Electronic Payment Processing Latency Issues
2025-12-02T15:14:00.0000000Z
2025-12-02T15:14:00.0000000Z
CUSI's transparent and effective client communication is a top priority, and we are committed to providing you with regular updates regarding CUSI products.
CUSI is currently investigating a payment processing latency issue.
Starting around 10:00 a.m. CST on 12/1/2025, it was reported that slow or stalled transactions were occurring across both the Customer Web Portal (CWP) and in-house payment systems.
- Customer Web Portal (CWP): Users are reporting that clicking the Pay button caused the page to spin indefinitely and eventually time out.
- In-house Payments: Users are experiencing delays with the Hosted Payment Form (HPF), including slow loading and significant lag when entering credit card details—characters appeared only after a noticeable delay.
Start Time: 12/1/2025 around 10:00am CST
Estimated Resolution: TBD
CUSI is working diligently to resolve the issue and will provide updates as soon as possible. Thank you for being so patient.
2025-12-10T14:03:00.0000000Z
2025-12-10T14:03:00.0000000Z
Resolved: Payment Processing Latency Issue
Status: ✅ Resolved
Start Time: 12/1/2025 at approximately 10:00 a.m. CST
Resolution Time: 12/10/2025
Summary
CUSI’s commitment to transparent and effective client communication remains a top priority. We appreciate your patience while we worked to resolve the recent payment processing latency issue affecting both the Customer Web Portal (CWP) and in-house payment systems.
Issue Details
- Customer Web Portal (CWP): Users experienced indefinite loading after clicking the Pay button, often resulting in timeouts.
- In-house Payments: The Hosted Payment Form (HPF) exhibited slow loading and significant lag when entering credit card details, causing noticeable delays in character input.
Root Cause
The latency was traced to a temporary performance degradation in the payment gateway integration layer, which caused transaction requests to queue and stall under peak load conditions.
Resolution
All systems have been fully restored, and payment processing is functioning as expected.
Next Steps
- Continuous monitoring of payment systems for stability.
- Additional safeguards to prevent similar latency issues in the future.
Thank you for your patience and understanding. If you experience any further issues, please contact CUSI Support at techsupport@cusi.com.