eCheck Payout Changes

Informational

eCheck Payout Changes

Status: Closed
Date:
End:
Duration: 13 days 23 hours 19 minutes
Affected Components:
CUSI Payment Services Stripe
Affected Groups:
CUSI
Update

CUSI is pleased to inform you of an enhancement to the eCheck funding process that was implemented yesterday morning at approximately 6:00 AM.

Summary of the Update:

  • eCheck payments will continue to batch daily, but the funding timeline to deposit to your bank has been significantly reduced.
  • This improvement aligns eCheck processing more closely with credit card deposits, eliminating the previous 5+ day delay.

Please Note:

  • This update does not apply retroactively. As a result, you may observe some recent eCheck transactions being funded before older transactions from last week. This is expected behavior.
  • We anticipate that all deposits will normalize within the next week, considering the upcoming holiday period.

We appreciate your understanding and cooperation as we continue to enhance your payment experience. Should you have any questions or require assistance, please contact our support team at techsupport@cusi.com.

Thank you for your continued partnership.

Update

CUSI is aware that some Stripe eCheck payments initiated before the server update on November 24th have not yet been deposited. We are actively working to resolve this issue and ensure all missing payouts are completed as soon as possible.

What Happened:
On Monday, November 24th, CUSI updated the Stripe server to improve eCheck deposit timelines. While most transactions processed as expected, a subset of payments that were in progress before the update did not fund as intended.

Our team is diligently addressing this and will provide updates as soon as the situation is fully resolved.

Monitoring

CUSI is announcing that a resolution has been successfully deployed to address the Stripe payout issue. Our technical team has made the necessary corrections, and is currently monitoring to ensure stability and effectiveness.

Current Status: Monitoring

Summary:
The transfer process for all previously unpaid eCheck transactions has been successfully completed. These deposits are expected to be received within 1–2 business days.

Details:

  • Due to Stripe’s batching process, previously unpaid transactions may be combined with today’s payments and deposited together.
  • The Payout Report will include the original transaction date for each payment.
  • No further action is required on your part.

Impact:
There should be no disruption to normal operations. However, the combined deposits may appear as a single lump sum in your account.

Next Steps:
Monitor your account for deposits over the next 1–2 business days. If you have questions, please contact our support team at techsupport@cusi.com.

Apology:
CUSI sincerely apologizes for any inconvenience this may have caused and appreciate your patience.

Resolved

Resolved: Enhancement to eCheck Funding Process

CUSI is pleased to announce that an enhancement to the eCheck funding process was successfully implemented on November 24 at approximately 6:00 AM.

Summary of the Update

  • eCheck payments will continue to batch daily.
  • The funding timeline for deposits to your bank has been significantly reduced, aligning eCheck processing more closely with credit card deposits.
  • This improvement eliminates the previous 5+ day delay.

Important Notes

  • This update does not apply retroactively. You may notice some recent eCheck transactions being funded before older transactions from last week—this is expected behavior.
  • All deposits are anticipated to normalize within the next week, considering the upcoming holiday period.

We appreciate your understanding and cooperation as we work to enhance your payment experience.
For questions or assistance, please contact our support team at techsupport@cusi.com.

Thank you for your continued partnership.