Payments Failing to Post to Billing System

Incident

Payments Failing to Post to Billing System

Status: Closed
Start:
End:
Duration: 3 hours 29 minutes
Affected Components:
CUSI Payment Services Stripe CUSI Payment Services Bluefin
Affected Groups:
CUSI
Investigating

CUSI's transparent and effective client communication is a top priority, and we are committed to providing you with regular updates regarding CUSI products.

CUSI is currently investigating an issue affecting electronic payment posting.

  • Start Time: 9/15/2025 at 11:25am CST

  • Impact: Electronic Payments are failing to post back to the billing system

  • Estimated Resolution: TBD

CUSI is working diligently to resolve the issue and will provide updates as soon as possible. Thank you for being so patient.

Monitoring

CUSI is announcing that a resolution has been successfully deployed to address electronic payment processing. Our technical team has made the necessary corrections, and is currently monitoring to ensure stability and effectiveness.

Current Status:

  • Resolution Deployed: The CUSI relay server is now successfully registering payments and returning accurate status updates. Postback responses are being delivered correctly, and the payment relay server has resumed normal operation. Users should no longer experience delays or issues processing payments.

  • Monitoring: CUSI is closely monitoring the performance and functionality to ensure that the issue has been fully resolved.

Actions Taken:

  • The technical team has identified and addressed the cause of the disruption.

  • Mitigation measures have been put in place to prevent recurrence.

  • Continuous monitoring is being conducted to track performance and detect any anomalies.

Next Steps:

  • Monitor Closely: Please be vigilant and report any irregularities or issues you may encounter.

  • Feedback: Feedback is crucial during this monitoring phase. If you notice any problems, please contact our technical support team immediately.

  • Updates: CUSI will provide regular updates on the status and any further actions required.

Resolved

CUSI is announcing that the tasks executed related to electronic payment processing have successfully addressed the issues as of 1:51pm CST.

Details of the Issue:

  • Issue Start Time: 9/15/25 at 11:34am CST

  • Duration: 2 hours 17 minutes

  • Affected Services:

    • CUSI Relay Server

What Happened:

The issue was caused by a processing delay in the relay server, which temporarily impacted the registration of payments and delivery of postback responses. The server has now recovered, and payment processing has resumed normal operation.

Resolution Steps:

  • Diagnosis: CUSI quickly diagnosed the issue, identifying the issue with CUSI's relay server.

  • Action Taken: CUSI implemented the following actions to resolve the issue:

    • CUSI has confirmed that all critical services—including payment processing, relay server operations, and security protocols—are functioning at optimal levels.

  • Verification: After confirming the resolution, CUSI thoroughly tested the services to ensure they function as expected.

Current Status:

As of now, all affected services are fully operational. Application users should experience normal performance and functionality.

Next Steps:

  • CUSI will continue to monitor the services closely to ensure stability.

  • If you encounter any issues, please report them to our support team at techsupport@cusi.com

Thank You:

CUSI sincerely apologizes for any inconvenience this outage may have caused and appreciate your understanding and patience. Your satisfaction is important to us.