Potential Bluefin Payment Processing Outage

Informational

Potential Bluefin Payment Processing Outage

Status: In progress
Date:
Affected Components:
CUSI Payment Services Bluefin
Affected Groups:
CUSI
Update

CUSI's transparent and effective client communication is a top priority, and we are committed to providing you with regular updates regarding CUSI products.

Bluefin has reported on https://status.bluefin.com/ a potential issue affecting their payment processing platform

  • Start Time: 9:16am CST

  • Impact: Users might not be able to make payments

  • Estimated Resolution: TBD

CUSI will provide updates as soon as possible. Thank you.

Identified

At 10:11 AM CST, Bluefin identified the root cause of the current processing outage and is actively working on a resolution.

We will continue to monitor the situation closely and provide updates as progress is made. Thank you for your patience and understanding while we work toward full resolution.

Monitoring

As of 2:09 PM CST, Bluefin has implemented a fix and are now actively monitoring the results to ensure stability.

While CUSI believes the issue is no longer presenting errors, Bluefin has not yet officially confirmed full resolution.

We will continue to monitor the situation closely and provide additional updates as progress is made. Thank you for your patience and understanding.