Relay Server Maintenance

Maintenance

Relay Server Maintenance

Status: Closed
Start:
End:
Duration: 15 minutes
Affected Components:
CUSI Payment Services Stripe CUSI Payment Services Bluefin
Affected Groups:
CUSI
Update

Relay Server Maintenance Notification:

CUSI will perform scheduled maintenance on our relay server to enhance our systems' performance, security, and reliability. During this time, the following services may be unavailable or experience intermittent issues:

·        Electronic Payment Processing - Payments will be temporarily unavailable during the one-hour maintenance window starting on 5/26/2025 at 9:00 PM CST. 


Maintenance Objectives:

·        We are conducting this maintenance to implement critical infrastructure upgrades aimed at enhancing overall speed and performance. 

What to Expect:

·         Downtime: Approximately 1 hour

Contact Information:

If you have any questions or concerns, don't hesitate to contact our support team at techsupport@cusi.com.

 

We appreciate your patience and understanding throughout the maintenance process.

Resolved

Relay Server Maintenance Complete:

The scheduled maintenance has been successfully completed. All systems are now fully operational. We appreciate your patience and understanding during this time.

If you experience any issues, please contact our support team at techsupport@cusi.com

Thank you for your continued trust in our service.