Credit Card Processing Issue
Incident Report for CUSI
Resolved
CUSI Clients experienced a brief connectivity issue when attempting to process Electronic Payments.
Service functionality has been restored at this time. The outage was approximately 21 minutes between 1:54PM and 2:15PM CST.

If you have received calls about failing payments during this time, please have them try again.

Thank you for your commitment to CUSI. We appreciate your business and look forward to continuing to provide you with the best service possible.

Thank you,

CUSI Technical Support
Posted Mar 07, 2023 - 14:26 CST
Update
We are continuing to investigate this issue.
Posted Mar 07, 2023 - 14:03 CST
Investigating
We are currently investigating an issue processing electronic payments within the CUSI software. We will post updates as soon as they become available.
Posted Mar 07, 2023 - 14:00 CST
This incident affected: CUSI Payment Services (CUSI Payment Services - Powered by Stripe, CWP - Payments) and Bluefin Payment Provider (Bluefin Payment Systems).