Bluefin Transaction Receipts
Incident Report for CUSI
Resolved
We have been notified by Bluefin that the inability to receive payout reports is no longer an issue If you did not receive a Bluefin payout report and require one, please reach out to our technical support team for assistance and we will be happy to help.

Thank you for your commitment to CUSI. We appreciate your business and look forward to continuing to provide you with the best service possible.
Posted Aug 09, 2023 - 09:18 CDT
Investigating
We're currently investigating reports of a potential service interruption with customers receiving emailed Bluefin Transaction receipts over the last few days. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Aug 07, 2023 - 11:27 CDT
This incident affected: Bluefin Payment Provider (Bluefin Payment Systems).