Investigating issues with Stripe Electronic Credit Card Processing
Incident Report for CUSI
Resolved
The Stripe electronic payment issue has been resolved at this time.

Thank you for your commitment to CUSI. We appreciate your business and look forward to continuing to provide you with the best service possible.

CUSI Technical Support
Posted Apr 03, 2023 - 10:45 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2023 - 08:29 CDT
Investigating
We're currently investigating reports of a potential service interruption with Stripe credit card processing and gateway reconciliation. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Apr 03, 2023 - 07:41 CDT
This incident affected: CUSI Payment Services (CUSI Payment Services - Powered by Stripe, CWP - Payments).