Investigating issues with CUSI Cloud Hosting
Incident Report for CUSI
Resolved
This incident has been resolved.
Posted Apr 28, 2023 - 13:44 CDT
Monitoring
We have resolved the issue and will be monitoring this throughout the day. If you experience any CUSI Cloud Hosting outages, please reach out to our Technical Support team.
Posted Apr 28, 2023 - 09:00 CDT
Investigating
We're currently investigating reports of a potential service interruption with CUSI Cloud Hosting. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Apr 28, 2023 - 07:35 CDT
This incident affected: Cloud Hosting (Azure Virtual Desktop).