Bluefin Electronic Credit Card Processing Payout Reports
Incident Report for CUSI
Resolved
We have been notified by Bluefin that payout reports for yesterday were delayed and processed today at approximately 7:05am CST. If you did not receive a Bluefin payout report and require one, please reach out to our technical support team for assistance and we will be happy to help.

Thank you for your commitment to CUSI. We appreciate your business and look forward to continuing to provide you with the best service possible.
Posted Jul 13, 2023 - 08:55 CDT
Investigating
We're currently investigating reports of Bluefin payout reports from yesterday not being sent out . Deposits should NOT be impacted . We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Jul 13, 2023 - 08:08 CDT
This incident affected: Bluefin Payment Provider (Bluefin Payment Systems).