Monitoring: Microsoft Network Infrastructure
Incident Report for CUSI
Resolved
This incident has been resolved. All systems should be fully operational.
Posted Jul 31, 2024 - 08:02 CDT
Update
We are continuing to investigate this issue.
Posted Jul 30, 2024 - 10:40 CDT
Investigating
Microsoft has implemented configuration changes and performed failovers to alternate networking paths to provide relief. CUSI has verified the Microsoft changes to our systems and confirmed service availability. We will continue to monitor and update as Microsoft provides additional information.
Posted Jul 30, 2024 - 10:30 CDT
This incident affected: CUSI Payment Services (CUSI Payment Services - Powered by Stripe) and Cloud Hosting (Azure Virtual Desktop).