CUSI Payment Relay Server, Customer Web Portal, and Hosted Solutions Outages
Incident Report for CUSI
Resolved
This incident has been resolved. All systems should be fully operational.
Posted Jul 19, 2024 - 08:41 CDT
Identified
We are still monitoring the issue with our payment relay server, customer web portals, and hosted solutions. We have identified the outage to the current Microsoft Azure Central US Region outage here: https://azure.status.microsoft/en-us/status.

We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Jul 18, 2024 - 20:37 CDT
Investigating
We’re currently investigating reports of a potential service interruption with our payment relay server. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Jul 18, 2024 - 18:04 CDT
This incident affected: CUSI Customer Web Portal (CWP 2.0) - Microsoft Azure Cloud Infrastructure (Microsoft Azure - South Central US Data Center, CWP) and CUSI Payment Services (CUSI Payment Relay Server, CWP - Payments).