Investigating Stripe Service Interruption
Incident Report for CUSI
Resolved
The Stripe electronic payment issue has been resolved at this time.

Thank you for your commitment to CUSI. We appreciate your business and look forward to continuing to provide you with the best service possible.

CUSI Technical Support
Posted Feb 29, 2024 - 08:57 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2024 - 17:19 CST
Investigating
We're currently investigating reports of a potential service interruption with Stripe credit card processing. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Feb 28, 2024 - 15:18 CST
This incident affected: CUSI Payment Services (CUSI Payment Services - Powered by Stripe, CUSI Payment Relay Server, CWP - Payments).