Mobile Meter Reading System (MMRS) Service Outage
Incident Report for CUSI
Resolved
The Mobile Meter Reading Service (MMRS) has been restored. If you had issues saving readings from your device, please try saving them again.

Thank you for your commitment to CUSI. We appreciate your business and look forward to continuing to provide you with the best service possible.

CUSI Technical Support
Posted Apr 04, 2023 - 14:54 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2023 - 13:29 CDT
Investigating
We're experiencing a service outage with our Mobile Meter Reading System (MMRS). Our team is currently working to restore the service. We apologize for any inconvenience. MMRS users may be affected. We will post a status update as soon as it becomes available.
Posted Apr 04, 2023 - 13:13 CDT
This incident affected: Mobile Meter Reading - MMRS.