Bluefin Payment Service Interruption
Incident Report for CUSI
Resolved
The incident surrounding Bluefin payments has been resolved. Please continue to monitor your payments/deposits for today's activity.
Posted Dec 07, 2023 - 17:01 CST
Investigating
CUSI has been notified of a service interruption with Bluefin payments. Their team of engineers is working to restore service as soon as possible. We will keep you updated as we have more information, or you can follow along with Bluefin updates directly at this link: https://status.bluefin.com/
Posted Dec 07, 2023 - 11:03 CST
This incident affected: Bluefin Payment Provider (Bluefin - Hosted Payment Form, Bluefin Payment Systems).