Vanco Payment Delays
Incident Report for CUSI
Resolved
This incident has been resolved.
Posted Jan 03, 2024 - 08:05 CST
Monitoring
Fiserv payments processed through Vanco will be settled on Tuesday, January 2nd. The late funded payments will be combined with the rest of your incoming payments from Fiserv on Tuesday, January 2nd.
Posted Dec 29, 2023 - 14:19 CST
Investigating
Vanco payments will be delayed due to a Fiserv processing issue. Vanco is working diligently with Fiserv to resolve this issue as soon as possible. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Dec 29, 2023 - 11:59 CST
This incident affected: Third-Party Integrations (Vanco Integration).