Discover Credit Cards Not Working
Incident Report for CUSI
Resolved
Resolved - This incident has been resolved. Feb 6, 17:17 EST
Posted Feb 06, 2023 - 19:49 CST
Update
We’ve seen elevated declines for Discover charges, as a result of an outage impacting the Discover card network. This outage is outside of CUSI's infrastructure. We are in contact with the card network and will provide updates here.
Posted Feb 06, 2023 - 15:02 CST
Investigating
Per Bluefin: We are investigating reports of processing issues affecting merchants utilizing Discover for processing payments. Our team of engineers is working with our contacts at Discover to find a solution. Please check back for further updates. We apologize for the inconvenience and we thank you for your patience.
Posted Feb 06, 2023 - 14:21 CST
This incident affected: Bluefin Payment Provider (Bluefin - Hosted Payment Form, Bluefin Payment Systems).