Investigating Issues with a USA E-Pay Outage
Incident Report for CUSI
Resolved
This incident has been resolved.
Posted Feb 06, 2024 - 15:37 CST
Monitoring
All systems are currently operational at this time, and we are currently monitoring the resolution. We will post another update as soon as we learn more.
Posted Feb 02, 2024 - 10:59 CST
Identified
The issue has been identified and we are working towards a resolution. We will keep you informed of any updates and thank you for your patience.
Posted Feb 01, 2024 - 15:39 CST
Investigating
We are experiencing a service outage with our USA E-Pay customers. Our team is currently working to restore the service as quickly as possible. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Feb 01, 2024 - 11:04 CST
This incident affected: CUSI Payment Services (USA E-Pay).