CUSI Managed Backup Services Outage
Incident Report for CUSI
Resolved
The issue affecting CUSI Managed Data Security Services has been resolved. If you continue to experience any service disruptions with managed backups, please do not hesitate to reach out to Technical Support.
Posted Apr 23, 2024 - 21:41 CDT
Investigating
Clients using CUSI Managed Data Security Services for CBSW or UMS backups may experience errors this evening with scheduled backups, preventing a successful daily backup. We are currently investigating this issue and will provide updates as we gather more information or a resolution is discovered.

We apologize for the disruption and appreciate your patience as we work to fully restore service functionality.
Posted Apr 23, 2024 - 14:36 CDT
This incident affected: CUSI Managed Data Services.