MMRS Service Outage
Incident Report for CUSI
Resolved
Service has been fully restored. Thank you for your patience.
Posted Sep 08, 2023 - 09:08 CDT
Investigating
We're experiencing a service outage with MMRS. Our team is currently working to restore the service. We apologize for any inconvenience.
Posted Sep 08, 2023 - 08:25 CDT
This incident affected: Mobile Meter Reading - MMRS.