Bluefin Hosted Payment Form Connection Error
Incident Report for CUSI
Resolved
Bluefin’s team of engineers have implemented a fix and we are monitoring the results. We apologize for the inconvenience and we thank you for your patience.
Posted Jul 06, 2023 - 14:24 CDT
Investigating
We are investigating reports of an issue on the PayConex Platform, we have received reports of clients having sporadic access to Payconex. Our team of engineers is currently working to fix the issue. We will follow up with updates as soon as we receive them. We apologize for the inconvenience and we thank you for your patience.
Posted Jul 06, 2023 - 13:07 CDT
This incident affected: Bluefin Payment Provider (Bluefin - Hosted Payment Form).