Payment Post Back Failures
Incident Report for CUSI
Resolved
CUSI Clients experienced a brief connectivity issue when attempting to process Electronic Payments.
Service functionality has been fully restored at this time.

Thank you for your commitment to CUSI. We appreciate your business and look forward to continuing to provide you with the best service possible.

Thank you,

CUSI Technical Support
Posted Dec 18, 2023 - 08:28 CST
Monitoring
We have identified the potential issue and implemented a fix. We will be monitoring the results and will update status as soon as we confirm the resolution.
Posted Dec 15, 2023 - 17:20 CST
Update
We are currently investigating an issue specifically with electronic payments and our relay server for our customers. We will update status as soon as it is available.
Posted Dec 15, 2023 - 15:25 CST
Investigating
CUSI is currently investigating reports of payments failing to post back to the billing system.
Posted Dec 15, 2023 - 14:51 CST
This incident affected: CUSI Payment Services (CUSI Payment Relay Server).