Investigating Issues with Emailed Bluefin Transaction Receipts
Incident Report for CUSI
Resolved
The Bluefin email issue has been resolved at this time.

Thank you for your commitment to CUSI. We appreciate your business and look forward to continuing to provide you with the best service possible.

CUSI Technical Support
Posted Mar 10, 2023 - 12:48 CST
Monitoring
A fix has been implemented and we are monitoring the results. We will provide additional updates as soon as we confirm this issue has been resolved.
Posted Mar 09, 2023 - 14:35 CST
Update
We are still working to resolve this issue with Bluefin. We will provide additional updates as soon as we have more information.
Posted Mar 08, 2023 - 16:56 CST
Investigating
We're currently investigating reports of a potential service interruption with customers receiving emailed Bluefin Transaction receipts. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Mar 08, 2023 - 10:38 CST
This incident affected: Bluefin Payment Provider (Bluefin Payment Systems).