Bluefin Outage: Failed Payments Through Billing Software
Incident Report for CUSI
Resolved
This issue is currently resolved and stabilized.
Posted May 13, 2022 - 08:26 CDT
Monitoring
We have identified the issue and have the following response from Bluefin. This is not an issue with CUSI billing software; Bluefin has made another update in which clearing cache should resolve in-house card payment processing issues.

Please take the following steps to resolve this issue:

https://fabricdigital.co.nz/blog/how-to-hard-refresh-your-browser-and-clear-cache#:~:text=using%20Internet%20Explorer-,Internet%20Explorer,key%2C%20click%20the%20Refresh%20button

Note: This link only works on non IE browsers (Safari, Chrome, Firefox).***

For IE browsers: You should manually clear the cache. Please reach out to CUSI Technical Support if you are in need of assistance.
Posted May 12, 2022 - 15:40 CDT
Investigating
There is currently a widespread issue with one of CUSI's merchant services providers – Bluefin. At this time, it seems to only impact payments attempted through the billing software. If your utility is experiencing these issues, we encourage you to use your Customer Web Portal or Inbound IVR system to accept card payments at this time. This page will be updated when the status returns to 'Normal.'
Posted May 12, 2022 - 13:18 CDT
This incident affected: Bluefin Payment Provider (Bluefin Payment Systems).