Stripe CC Processing
Incident Report for CUSI
Resolved
We have identified the issue specifically on older versions of our software and have a fix available. Please contact our Technical Support team if you are still experiencing any issues.
Posted Sep 30, 2022 - 15:33 CDT
Update
We are continuing to investigate this issue.
Posted Sep 30, 2022 - 10:25 CDT
Update
We are continuing to investigate this issue.
Posted Sep 30, 2022 - 10:21 CDT
Investigating
We are currently investigating an outage with Stripe CC processing and any updates will be provided when available.
Posted Sep 30, 2022 - 10:18 CDT
This incident affected: CUSI Payment Services (CUSI Payment Services - Powered by Stripe).